<!DOCTYPE html>
<html class='controller-contents'>
<head>
<script>window.NREUM||(NREUM={});NREUM.info={"beacon":"bam.nr-data.net","errorBeacon":"bam.nr-data.net","licenseKey":"def25c5cff","applicationID":"21817424,115551496","transactionName":"cwtcFxRXXF4ERBhSWV4QVw0SF1NdD0JSX0JDS0ELCU8=","queueTime":4,"applicationTime":501,"agent":""}</script>
<script>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</script>
<!-- GUCE -->
<meta content='false' name='oath:guce:product-eu'>
<meta content='guce.rivals.com' name='oath:guce:consent-host'>
<script src="https://s.yimg.com/oa/guce.js" async="async"></script>
<script>
  var googleAnalyticsId = "UA-81886974-1";
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','https://www.google-analytics.com/analytics.js','ga');
  
  ga('create', googleAnalyticsId, 'auto');
</script>

<link href='https://fonts.googleapis.com/css?family=Roboto:400,500,700|Merriweather:400,700,italic' rel='stylesheet'>
<link href='https://fonts.googleapis.com/css?family=Roboto+Condensed:400,500,700|Merriweather:400,700,italic' rel='stylesheet'>
<link href='https://cdnjs.cloudflare.com/ajax/libs/selectize.js/0.8.5/css/selectize.default.css' rel='stylesheet'>
<link href='https://cdn.rivals.com/production/assets/YahooSansFonts-7bf9e355b46ff060654c148212a35d40cb49b73381f27a9833dcc432fff1c97a.css' rel='stylesheet'>
<script src="https://cdn.rivals.com/production/packs/js/application-00d3833f203da5348147.js"></script>
<link rel="stylesheet" media="screen" href="https://cdn.rivals.com/production/packs/css/application-beb8821f.css" />
<title>AggieYell.com  -  AggieYell Mailbag</title>
<meta content='AggieYell.com  -  AggieYell Mailbag' property='og:title'>

<link rel="stylesheet" media="all" href="https://cdn.rivals.com/production/assets/application-46b4b2741e17e562e460e7157d02a79dd377e484524981b9c5dddcc9f9653cf6.css" />


<script src="https://cdn.rivals.com/production/assets/lib-12381f29bb2a6e1cd6ab2484aa7e729e8f72a6f1457e3a239ac156581f11a919.js"></script>
<script src="https://cdn.rivals.com/production/assets/application-6b8f88cd2c9fef0bc769e27eddb7d8e595b841606defa788ebd768702ed06240.js"></script>

<meta name="csrf-param" content="authenticity_token" />
<meta name="csrf-token" content="ED6svPU9kW5mwLw84e4uSbzkaor29V23BHnmR8jkC5PRU2EFsDmqicsBWGK+6n6BfPi+5+HEuDomTa3yuIJEFw==" />
<script>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</script>
</script>

<meta content='initial-scale=1.0, width=device-width, maximum-scale=1.0' name='viewport'>
<meta content='https://cdn.rivals.com/production/assets/favicons/browserconfig-273d00a84d0505fdc2d9beb1315850199c1ab215394a98be1a63372ca20207de.xml' name='msapplication-config'>
<meta content='#0a4ea3' name='msapplication-TileColor'>
<meta content='https://cdn.rivals.com/production/assets/favicons/mstile-144x144-bbea1de48acc36b36c4ecbc46ec3289e31950d22f6370c08529de09bfece57b8.png' name='msapplication-TileImage'>
<meta content='#ffffff' name='theme-color'>
<meta content='https://tamu.rivals.com/news/aggieyell-mailbag-279' property='og:url'>
<meta content='https://cdn.rivals.com/image/upload/f_auto,q_auto,t_headline_primary/qfotbj6qwllwzc8jivam' property='og:image'>
<meta content='A fully loaded AY Mailbag has arrived!' property='og:description'>
<meta content='article' property='og:type'>
<meta content='2019-05-16 10:42:14 -0500' property='article:published_time'>
<meta content='2019-05-16 10:42:15 -0500' property='article:modified_time'>
<meta content='Article' property='article:section'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-57x57-7404e8851b384e973afdb1115390a36947dbf5fe28a232d84e5c6908cd7705d5.png' rel='apple-touch-icon' sizes='57x57'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-60x60-6648de94c2c3e41f6513ac5c0467ffd19f7c02e65a0fc936f1a9982f3ed748c8.png' rel='apple-touch-icon' sizes='60x60'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-72x72-8f5bdbc6adbf0c5fba8e0fcac9577fd4d33e68420787ee56f609e500a58b921f.png' rel='apple-touch-icon' sizes='72x72'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-76x76-6fe5688966b66892f842e9c4a9024cbca3c4cb1924d64c8d62a0ddbf47fc68e9.png' rel='apple-touch-icon' sizes='76x76'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-114x114-0372b897e5d8e989c1aeb7b4c620e3a3d1d7ce7406faf9ba0bfa6848c33b920a.png' rel='apple-touch-icon' sizes='114x114'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-120x120-783a1158ba513dae40547a7466182cab45cdd11c5d875c25c4c47b5da51c027e.png' rel='apple-touch-icon' sizes='120x120'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-144x144-8241e0d11a6d3b792f7ff1728e23e8d3d4c06a582e090d29c3dd0e3c075a9105.png' rel='apple-touch-icon' sizes='144x144'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-152x152-7882a3d3bb9b9b3b702c4e642b2c161e2efc0e47150051764e987199e58bd8c0.png' rel='apple-touch-icon' sizes='152x152'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-180x180-07196b8cded86c2a4bf5c14f585d72da8fb6c20c3246efc59fa27678059c9940.png' rel='apple-touch-icon' sizes='180x180'>
<link href='https://cdn.rivals.com/production/assets/favicons/favicon-16x16-8f32636231ae820b22a672b74aedfff6c3106cccaeb865a002330d943f6910f4.png' rel='icon' sizes='16x16' type='image/png'>
<link href='https://cdn.rivals.com/production/assets/favicons/favicon-32x32-c81451fd0d87890abd08b9db0a795d10339bb7c12662e9e9f3c15ac330bdaf9a.png' rel='icon' sizes='32x32' type='image/png'>
<link href='https://cdn.rivals.com/production/assets/favicons/favicon-96x96-8df131d801eebf824632ce95b824704d0a928c3cf453c5222cbe555c87b1eb0f.png' rel='icon' sizes='96x96' type='image/png'>
<link href='https://cdn.rivals.com/production/assets/favicons/favicon-194x194-728b6833bcd8ec9ff9fa15aba3595de5b9df51530f29547457c749719f1f0b8d.png' rel='icon' sizes='194x194' type='image/png'>
<link href='https://cdn.rivals.com/production/assets/favicons/android-chrome-192x192-e7e88ca08f6e98bf706fceb62b57f86c338da64c83252bcc5a8b2f35fd89f191.png' rel='icon' sizes='192x192' type='image/png'>
<link href='https://cdn.rivals.com/production/assets/favicons/production-6bceccff7fae6f5e335858ba74b8e9ac335e7bf9d420edf1f92ecb7b9fdee02d.ico' rel='shortcut icon'>
<link href='https://cdn.rivals.com/production/assets/favicons/manifest-5ab6bada83e2c243aec32edcf5f419498d7897c6cfcca56ba6b1a16c7091f14d.json' rel='manifest'>
<script>
  var _sf_async_config = _sf_async_config || {};
  var subdomain = "tamu.rivals.com";
  /** CONFIGURATION START **/
  _sf_async_config.uid = 63621; // ACCOUNT NUMBER
  _sf_async_config.domain = subdomain;
  _sf_async_config.flickerControl = false;
  _sf_async_config.useCanonical = true;
  /** CONFIGURATION END **/
  var _sf_startpt = (new Date()).getTime();
</script>
<script async src='//static.chartbeat.com/js/chartbeat_mab.js'></script>

</head>
<body class='tamu contents-show' ng-app='rivals'>
<script>
  angular.module('rivals').run(function(googleAnalyticsService) {
    googleAnalyticsService.setGaClientId();
    })
</script>

<!--[if lte IE 9]><div class='browser-unsupported'>
<div class='browser-unsupported-text'>
You are using an
<strong>outdated</strong>
browser. Please
<a href='http://browsehappy.com/'>upgrade your browser</a>
to use Rivals.com
</div>
</div><![endif]-->

<style>
  /*doc
     ---
     title: Yahoo Heading & Body
     category: typography
     ---
   ```haml_example
  .font-yahoo-h2 Font Yahoo H2
  .font-yahoo-h3 Font Yahoo H3
  .font-yahoo-h4 Font Yahoo H4
  
  .font-yahoo-b4 Font Yahoo B4
  .font-yahoo-b5 Font Yahoo B5
   ```
  */
  @media screen and (max-width: 1023px) {
    .tamu #programming > h1 {
      background-color: #5d1024 !important; } }
  .tamu .wrapper-container .team-colors-line {
    background-color: #7f1f38; }
  .tamu .team-colors-line {
    width: 100%;
    height: 8px;
    display: flex;
    background-color: #5d1024; }
    .tamu .team-colors-line .color {
      width: 33.33%; }
    .tamu .team-colors-line .first-opacity {
      background-color: white;
      opacity: 0.2; }
    .tamu .team-colors-line .second-opacity {
      background-color: white;
      opacity: 0.4; }
    .tamu .team-colors-line.vertical {
      flex-direction: column;
      height: auto;
      width: 8px; }
      .tamu .team-colors-line.vertical .color {
        width: 100%;
        height: 33.33%; }
    .tamu .team-colors-line.header {
      height: 6px; }
  .tamu > header .notification-link .count-container {
    background-color: #5d1024 !important; }
  .tamu > header .wrapper-container {
    background-color: #5d1024 !important;
    display: block;
    position: fixed;
    top: 0px;
    width: 100%;
    z-index: 999; }
    @media screen and (min-width: 768px) {
      .tamu > header .wrapper-container {
        border-bottom: 6px solid #7f1f38 !important; } }
  .tamu > header .invalid-email-banner {
    background-color: #5d1024;
    height: 40px;
    line-height: 40px;
    position: relative;
    text-align: center;
    width: 100%;
    z-index: 998; }
    .tamu > header .invalid-email-banner a {
      color: #fff;
      vertical-align: middle; }
    .tamu > header .invalid-email-banner a:hover {
      color: #7f1f38; }
  @media screen and (max-width: 767px) {
    .tamu > header .mobile-header {
      background-color: #7f1f38 !important;
      height: 5px;
      position: fixed;
      width: 100%;
      z-index: 50; } }
  .tamu > header hr {
    background-color: rgba(255, 255, 255, 0.55) !important; }
  .tamu > header .home {
    border-right: 1px solid rgba(255, 255, 255, 0.55) !important; }
  .tamu > header .second-nav {
    background-color: white !important; }
  @media screen and (max-width: 1023px) {
    .tamu > header .nav-row > ul,
    .tamu > header .third-nav {
      background-color: white !important; }
    .tamu > header .dropdown-toggle > i.fa {
      color: #5d1024 !important; } }
  .tamu > header .active {
    font-family: "Roboto", "Helvetica Neue", arial, sans-serif;
    font-weight: 500;
    color: #5d1024; }
  
  .site-primary-font-color {
    color: #5d1024; }
  
  .site-primary-background-color {
    background-color: #5d1024; }
  
  .site-secondary-font-color {
    color: #7f1f38; }
  
  .site-secondary-background-color {
    background-color: #7f1f38; }
  
  .team-background-image {
    background-image: linear-gradient(rgba(93, 16, 36, 0.4), rgba(93, 16, 36, 0.4)), url();
    background-repeat: no-repeat;
    background-position: center; }
  
  :root {
    --primary-color: #5d1024;
    --secondary-color: #7f1f38;
    --accent-color: #5d1024;
    --button-color: #5d1024; }
</style>

<header><nav ng-class='ctrl.currentUser ? "signed-in" : "signed-out"' ng-cloak ng-controller='NavController as ctrl' ng-init='ctrl.init(false)' role='navigation'>
  <div class='wrapper-container'>
    <div class='wrapper logo-row'>
      <a alt="Rivals" href="https://rivals.com"><div class='rivals-logo-navbar-white'></div>
      </a>
      <a class='nav-menu-mobile' ng-click='ctrl.toggleContentNav($event)'></a>
      <a alt="Texas A&amp;M" class="site-header" ng-class="ctrl.teamSite ? &quot;team&quot; : &quot;no-team&quot;" href="https://tamu.rivals.com/"><img src="https://res-4.cloudinary.com/rivals/image/upload/jy8pxbvl2wmcnknespsg" alt="Jy8pxbvl2wmcnknespsg" />
      </a>
      <div class='nav-right-controls'>
        <div class='subscribe-section' ng-cloak ng-if='ctrl.showSubscribe()'>
          <span>
            Join the team!
          </span>
          <a ng-href='{{ ctrl.subscribePath }}'>
            Subscribe
          </a>
        </div>
        <rv-universal-search></rv-universal-search>
        <rv-user-dropdown current_user='ctrl.currentUser'></rv-user-dropdown>
        <rv-forums-info current_user='ctrl.currentUser' ng-if='ctrl.currentUser && !ctrl.isMobile'></rv-forums-info>
      </div>
    </div>
  </div>
  <div class='mobile-header'></div>
  <rv-header-alert class='alert-nav' scroll-min='40'></rv-header-alert>
  <hr>
  <div class='nav-row-container'>
    <div class='wrapper nav-row navbar-full' ng-cloak ng-if='!ctrl.isTablet'>
      <ul>
        <li class="home top-nav"><a href="https://tamu.rivals.com/">Home</a></li>
        <rv-forum-navigation school-identifier="&#39;tamu&#39;" limit="8"></rv-forum-navigation>
        <li class="search top-nav"><a href="/search">Prospect Search</a></li>
        <rv-navigation navigation="ctrl.schoolByGroupDivision"></rv-navigation>
        <rv-user-menu-items current-user="ctrl.currentUser" ng-if="!ctrl.isTablet &amp;&amp; !ctrl.isDesktop" class="user-menu"></rv-user-menu-items>
      </ul>
    </div>
    <div class='wrapper nav-row navbar-ellipsed' ng-cloak ng-if='ctrl.isTablet'>
      <ul>
        <li class="home top-nav"><a href="https://tamu.rivals.com/">Home</a></li>
        <rv-forum-navigation school-identifier="&#39;tamu&#39;" limit="4"></rv-forum-navigation>
        <li class="search top-nav"><a href="/search">Prospect Search</a></li>
        <rv-navigation navigation="ctrl.schoolByGroupDivision"></rv-navigation>
        <rv-user-menu-items current-user="ctrl.currentUser" ng-if="!ctrl.isTablet &amp;&amp; !ctrl.isDesktop" class="user-menu"></rv-user-menu-items>
      </ul>
    </div>
    <div class='nav-row invalid-email-banner' ng-cloak ng-if='ctrl.showEmailUpdateBanner'>
      <a ng-href='{{ctrl.userProfileEditPath}}'>
        Your account has an invalid email address. Please update it here.
      </a>
    </div>
  </div>
</nav>
</header>
<div class='alert-placeholder'>
<rv-header-alert class='alert-nav'></rv-header-alert>
</div>
<main class='wrapper'><script src="https://s.yimg.com/ss/rapid-3.24.js"></script>
<script>
  YAHOO.i13n.WEBWORKER_FILE = "js/rivals/analytics/rapidworker-1.2.js";
  
  var rapid = new YAHOO.i13n.Rapid({
    spaceid: 2022733148,
    ywa: {
      project_id: 10002066977754,
      document_group: 'content',
      member_id: 0
    },
    nol: 1,
    client_only: 1
  });
</script>

<script>
  var contentTitle = "AggieYell Mailbag"
</script>
<meta content='summary_large_image' name='twitter:card'>
<meta content='@Rivals' name='twitter:site'>
<meta content='AggieYell Mailbag' name='twitter:title'>
<meta content='A fully loaded AY Mailbag has arrived!' name='twitter:description'>
<meta content='https://res-2.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_large/qfotbj6qwllwzc8jivam' name='twitter:image'>
<div class='article-container-wrapper' ng-controller='ContentController' ng-init='init(nil, {"id":139,"legacy_id":893,"name":"AggieYell.com","friendly_name":"Texas A\u0026M","annual_discount":null,"subdomain":"tamu","primary_color":"5d1024","secondary_color":"7f1f38","font_color":"ffffff","short_name":"tamu","maple_ncaaf_team_id":84,"maple_ncaaf_endpoint":"ncaaf/teams/ttj","maple_ncaab_team_id":587,"maple_ncaab_endpoint":"ncaab/teams/tan","maple_college_id":84,"google_analytics_id":"UA-81886974-1"}, true, 101, nil, {"id":49,"primary_color":"5d1024","secondary_color":"7f1f38","font_color":"ffffff","commitment_module_football":true,"rivals_module_football":true,"header_name":"","header_logo_cloudinary":"jy8pxbvl2wmcnknespsg","mobile_header_logo_cloudinary":null,"google_analytics_id":"UA-81886974-1","logo_background_shading":"white","football_content":true,"basketball_content":true,"baseball_content":true,"other_content":true,"site_id":139,"created_at":"2016-11-23T13:38:42.271-06:00","updated_at":"2019-01-14T19:00:08.106-06:00","max_trending_articles":6,"enrichments":[{"active":true,"type":"Commitment","football":true,"list_id":null,"list_title":null,"position":1},{"active":true,"type":"Rivals","football":true,"list_id":null,"list_title":null,"position":2},{"active":true,"type":"Schedule","football":true,"list_id":null,"list_title":null,"position":3},{"active":false,"type":"Twitter","football":null,"list_id":null,"list_title":null,"position":null},{"active":false,"type":"ScoreboardScores","football":null,"list_id":null,"list_title":null,"position":null},{"active":false,"type":"ScoreboardPhotos","football":null,"list_id":null,"list_title":null,"position":null},{"active":false,"type":"TeamRankings","football":true,"list_id":null,"list_title":null,"position":null},{"active":false,"type":"FanFuturecastLeaderboard","football":null,"list_id":null,"list_title":null,"position":null}],"footer_text":null,"sections":[],"supplied_domain":null,"message_board_link_url":"https://tamu.forums.rivals.com","scoreboard_scores_id":null,"scoreboard_photos_id":null,"aol_player_id":"59643b628c08e021702e776b","aol_company_id":"595e58902a30cb7ee3e53927","ad_frequency":5,"display_twitter_follow":false,"display_fb_follow":false,"follow_twitter_handle":null,"follow_fb_handle":null,"forum_id":null,"premium_forum_id":null,"facebook_page_id":null,"max_ticker_articles":7,"schedule_header_on":true,"promo_popup_on":false,"facebook_developer_id":null,"customized_tos":[],"show_survey_popup":false,"survey_popup_link":null,"header_bottom_border_style":"solid","premium_icon_url":null},&#x000A;"59643b628c08e021702e776b", "595e58902a30cb7ee3e53927", "rivals", 15000, false, {"id":115,"user_id":1089,"site_id":139,"updated_at":"2017-08-01T21:17:04.092-05:00","publisher_name":"Mark Passwaters","first_name":"Mark","last_name":"Passwaters","site_title":"Publisher","bio":"","twitter_handle":"mbpRivals","image_url":null,"publisher_name_and_title":"Mark Passwaters, Publisher","site_name":"AggieYell.com","site_short_name":"tamu","has_edited_profile":true})'>
<div class='horizontal-ad-container'>
<div id='boxLDRB'>
<div id='tgtLDRB'></div>
</div>
</div>

<div class='article-container' ng-class='{"no-ad-padding": "#{@display_ldrb_top}"}'>
<div class='upsell-forecast-banner' ng-cloak='true'>
<rv-user-forecast-banner class='forecast-banner' upsell='true'></rv-user-forecast-banner>
</div>
<div class='left-side-modules-container siderail'>
<div class='left-modules-container'>
<div class='news-list homepage-module'>
<div class='section-header'>
News
<a href="/more_news#other-news"><span class='more-news-link'>
More News
</span>
</a></div>
<rv-news-ticker contents='newsList' is_preview='false' is_publisher='isPublisher' profile_page='false' referral_code='referralCode' team='false'></rv-news-ticker>
</div>

<div class='side-rail-meta lrec-ad' ng-if="showLRECad('leftrail-below-ticker')">
<div class='side-rail-box'>
<div id='boxLREC'>
<div id='tgtLREC'></div>
</div>
</div>
</div>
<div class='side-rail-meta lrec-ad2'>
<div class='side-rail-box'>
<div id='boxLREC2'>
<div id='tgtLREC2'></div>
</div>
</div>
</div>

<rv-message-boards ad-referer='https://tamu.rivals.com/news/aggieyell-mailbag-279' base-api-url='https://tamu.forums.rivals.com/' homepage='false' message-board-url='https://tamu.forums.rivals.com' pub-ad='null' size='size' space-id='2022733148' subscribed-user='subscribedUser'></rv-message-boards>

<div class='video-ad-wrapper'>
<script async src='//c.jsrdn.com/s/cs.js?p=22546' type='text/javascript'></script>
<div class='video-container' id='ds_default_anchor'></div>
</div>
</div>
</div>
<div class='article-display-wrapper'>
<div class='article-content'>
<div class='article-header'>
<div class='pull-right'>
<rv-share-links collapsed='true' print-url='https://tamu.rivals.com/news/aggieyell-mailbag-279/printable' site-name='AggieYell.com'></rv-share-links>
</div>
<span class='article-header-age' ng-cloak>{{ timeAgo('2019-05-16 10:42:14 -0500') }}</span>
<span class='article-header-sport'>football</span>
<a class='edit-article updated-article-page' href='{{editPath(publishedSite)}}//publishing/contents/2042991/edit' ng-cloak ng-show='isPublisher'>Edit</a>
</div>
<h2 class='article-title'>AggieYell Mailbag</h2>
<div class='header-image'></div>
<div class='author-byline'>
<div class='flex-container'>
<div class='vertical-align'>
<span>
<span class='author-name'>
Mark Passwaters
&bull;
</span>
<span class='type-sm'>AggieYell.com</span>
<div class='type-sm'>
<a href='//twitter.com/mbpRivals' target='_blank'>@mbpRivals</a>
</div>
</span>
</div>
<div class='vertical-align link-button' ng-click='authorBio()' ng-cloak>
<div class='caret-down' ng-cloak ng-show='!expandProfile'></div>
<div class='caret-up' ng-cloak ng-show='expandProfile'></div>
</div>
</div>
<div class='expanded-content' ng-cloak ng-if='expandProfile'>
<div class='flex-container'>
<span>
<span class='author-name'>Publisher</span>
</span>
<script async charset='utf-8' src='//platform.twitter.com/widgets.js'></script>
<a class='twitter-follow-button' data-show-count='false' data-show-screen-name='false' data-size='large' href='//twitter.com/mbpRivals'></a>
</div>
<div class='type-sm' ng-cloak ng-if='expandProfile'>

</div>
</div>
</div>
<div class='article-body-container'>
<div class='body-wrapper'>
<div class='article-body'><h3 class='article-heading'>Here's the latest edition of the AggieYell Mailbag...</h3>
<div class='st__content-block st__content-block--text article-text'>
<p><b>Q: Latest on AD search?</b></p><p>not much right now. Seems to be in a holding pattern.</p><p><b>Doesn't seem like recruiting is super hot right now. What gives?</b></p><p> It’s much better than you think. </p><p><b>Buzz's class done? (AG_2000)</b></p><p> I doubt it.</p><p><b>Q: Do you think any of the ex-BillyBall basketball players that entered the portal or decommitted will (1) be asked to come back or (2) actually come back? And does Flagg have even a chance of getting drafted? I’m not seeing it. (h273)</b></p><p>A: A: no and no. They’re all going somewhere else.</p><p>I really doubt he gets drafted but the idea may be to go through the process, see where he stands and then decide whether to come back or stay in. The advice right now has to be for him to come back.</p><p><b>Q: 1) What is Jimbo looking for (philosophy) in a RB (he has offered all different heights and weights of RB's)?</b></p><p> A: he’s looking for someone who he believes can be an every down back in a pro-style system. He’s done it with every size of back in the past.</p><p><b>2) How would you rank these RB's (like in order of priority for TAMU's offensive system)?We have offered:</b></p><p><b>Zach Evans - 5 star - #1 RB</b></p><p><b>Kendall Milton - 5 star - #2 RB (looks favored to OU)</b></p><p><b>MarShawn Lloyd - 5 star - #4 </b></p><p><b>RBJase McClellan - 4 star - #5 RB (committed - OU)</b></p><p><b>Bijan Robinson - 4 star - #7 RB</b></p><p><b>EJ Smith - 4 star - #8 RB</b></p><p><b>Daniyel Agata - 4 star - #9 RB</b></p><p><b>Sam Adams - 4 star - #11 RB (looks favored to Washington)</b></p><p><b>Lamy Constant - 4 star #14 RB</b></p><p><b>Seth McGowan - 4 star #16 RB (huslin' one)</b></p><p> It’s probably in this order, among the guys you mentioned: Evans, McGowan, Smith, Adams. </p><p><b>Q: With spring training in the rear view mirror, you have noted DB's Devin Morris &amp; Moses Reynolds had good spring performances. Are they in the top 2 tiers of the Depth Chart? Sounds like Morris should be on kick coverage. </b></p><p> I would doubt it, but Morris should be a gunner on coverage teams.</p><p><b>Were DE's Camron Horry and Ondario Robinson active in spring practice? </b></p><p>Yes.</p><p><b>​What is the status of DE's Camron Horry and Ondario Robinson? (raraeo)</b></p><p>On the team, buried on the depth chart.</p><p><b>Q: Will Saban’s inability to keep staff continuity (7 coaches changed each of the last 2 seasons) translate into lower ranked recruiting classes for Bama as well as the rest of the SEC (A&amp;M, Auburn, LSU) routinely beating the Crimson Tide? (Boxsterboy72)</b></p><p> A: is Saban still the coach? Yes? Then no.</p><p><b>Q: 1. How many commits will we have by the end of May?</b></p><p>More than they have now.</p><p><b>2. How many before the first game?</b></p><p>More than that. Bluntly, these are impossible questions to answer.</p><p><b>3. Do we need a QB and RB in this class?</b></p><p>You're kidding, right? Absolutely yes, they do.</p><p><b>4. Will we look at JUCO players other than the Blinn DB? (AggieLuke04)</b></p><p>A: Maybe one or two, but that's it. </p><p><b>Q: Will Cashius McNeily qualify as part of the Class of 2019? (oldarmy72) </b></p><p>A: He signed Monday. </p><p><b>Q: Would you attribute any of our slow recruiting pace to losing Tim Brewster? (map87)</b></p><p><b> What’s up with recruiting? How come we’re so far behind LSU we can never catch up? Brewster? (Strobafett) </b></p><p>A: ok, let’s establish something: Tim Brewster is an excellent recruiter. But he didn’t recruit everyone all the time. This idea that he made the 2019 class is, for lack of a better term, ridiculous. Terry Price, Maurice Linguist and Dameyune Craig deserve a lot more credit than anyone has given them. And like I said, recruiting isn’t a disaster like some of you are making it out to be. They’re in on a lot of guys around the nation and lead for several of them. </p><p><b>Q: Are you concerned about the lack of Seniors on the roster? Why or Why not?</b></p><p> I am, but largely because they have so many juniors on the roster that have had to fill that void. That means attrition after 2020 will be terrible.</p><p><b>List two reasons why the offense will be better than last year. (brAG)</b></p><p> More experienced QB, improved wideouts.</p><p><b>Q: What are the issues with our BOR in regards to consistency and retaining quality AD's? (Big Smoothie)</b></p><p>A: ADs, plural? They’ve had <i>one.</i></p><p><b>Q: Will Rivals ever shift to more actual game film and offer lists to rank prospects? (ag98) </b></p><p>A: no idea. I don’t ask and they don’t tell me.</p><p><b>Q: How do the two holdovers from the last recruiting year count toward the rankings? Just curious.</b></p><p>I don’t think they do. </p><p><b> Was interested in your list of scholly juniors. Definitely some guys on that list that step up or move on, but there’s plenty of talent too. I’m with you...I can’t figure out how we open up that many spots. So here’s my question: in the Summy years, there always seemed to be positions with glaring holes and others with way too many players. Fisher recruited a very balanced class last cycle. Can you speculate on position groups that need to see above average attrition to build a more balanced roster for the future? Where do we look to find those extra spots? (elicrow)</b></p><p>A: I think you can cut into it by looking at guys who have been here two years or more and haven’t made it on the field. For me, that would mean looking at both lines, wideout and corner. I’m not going to name names, but look at the roster. You’ll probably lock onto some names pretty quickly.</p><p><br></p><p><b><br></b></p><p><br></p><p><b><br></b></p><p><br></p>
</div>
<figure class='article-image' ng-controller='rvFullImageController as ctrl' ng-init="ctrl.init('https://res-2.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_large/qfotbj6qwllwzc8jivam','https://res-2.cloudinary.com/rivals/image/upload/f_auto,q_auto/qfotbj6qwllwzc8jivam')">
<div class='blurred-image image-with-caption'>
<div class='background' style='background-image: url(https://res-2.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_large/qfotbj6qwllwzc8jivam)'></div>
<div ng-class='{"clickable-image": ctrl.isFullSizeBigger()}' ng-click='ctrl.showModal()'>
<img src="https://res-2.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_large/qfotbj6qwllwzc8jivam" alt="Qfotbj6qwllwzc8jivam" />
<div class='zoom-image'></div>
</div>
</div>
<div class='team-colors-line'>
<div class='color'></div>
<div class='color first-opacity'></div>
<div class='color second-opacity'></div>
</div>
<figcaption class='image-caption'>If Kellen Mond takes the next step, the Aggie offense will be better in 2019.</figcaption>
</figure>
<div class='st__content-block st__content-block--text article-text'>
<p><b>Q: What DE’s will we sign in 2020. Are any of them candidates to move inside a la Bobby Brown? (phastman) </b></p><p> A: they have a lot of irons in the fire, so I can’t say right now. But looking at the list, I don't think so.</p><p><b>Q: What prospect (committed or not) could have the biggest and most immediate impact on the program? (hogtide) </b></p><p>A: they’re committed: Demond Demas and Jaylon Jones.</p><p><b>Q: Between Morris and Hayes which is more likely to commit to A&amp;M? (agcatter123)</b></p><p>A: King.</p><p><b>Q: 1. Is there a maximum age limit for college football?</b></p><p><b>2. Any chance we get Samford on our schedule now? (TAMU-83) </b></p><p>A: No and no.</p><p><b>Q: If we push for Chandler Morris do you think he could be part of this class? Him being a legacy I bet he would listen. (carterr66)</b></p><p>A: ah, the "we gotta get this kid because he's a legacy" virus pops up again. How about they focus on getting the most talented kid available? It seems pretty clear that they believe King is that player (right now).</p><p><b>Q: Seems like we are in good shape with Troy O, the WR from North Carolina and Devin Price. Would we take all 3 or is it first two to commit? (aggiewoo)</b></p><p>A: That's an excellent question and I'm not sure <i>anyone</i>, including the coaching staff, has a concrete answer for it. Personally, I like all three and would try to take them. A&amp;M would have the best receiver class in the nation by a wide margin.</p><p><b>Q: I can't help but think that the diamond sports have underachieved, certainly in terms of trips to the world series. In your lifetime, what sport has been the biggest underachiever? </b></p><p>Football. No doubt.</p><p><b>What sport has overachieved? </b></p><p>Women's soccer, but more recently, it has to be the track teams.</p><p><b>What incoming player do you think will have the biggest impact once they make it to campus, other than Blades? Thanks. (Riffraff81)</b></p><p>Tough one. The fastest impact could be Brian Williams. I also think you have to watch Kenyon Green and Isaiah Spiller.</p><p><b>Q: How do you see Kellen Mond performing this year?</b></p><p><b>Do you think he will hold up to possibly playing 4 top 5 teams this year? (staubach1972)</b></p><p>A: I think he'll improve. The line should be better (I hope) and he's got a lot of weapons to work with. Most importantly, he's got a full year and then some in Jimbo's system.</p><p><b>Q: how many avail scholarship for basketball on Buzz.. (AGGIEDOG)</b></p><p>A: That depends on Savion Flagg. But they lost Isaiah Jacey at mid-season, then Amond Gilder, Brandon Mahan and John Walker are all transferring. At season's end, I only counted nine scholarship players anyway, and Christian Mekowulu graduated. So he's got a couple more at least, I would think. The maximum you can have is 15 scholarship players, and right now I count TJ Starks, Jay Jay Chandler, Wendell Mitchell and Josh Nebo as returning. Then you've got Cashius McNelly who has signed. Emanuel Miller, Josh Gordon, Quenton Jackson and Yavuz Gultekin are committed and should sign if they haven't already. That's 9, or 10 if Flagg returns. So five if he wants to use them all.</p><p><b>Q: 1. Was there a critical need position that wasn't filled in the 2019 recruiting class?</b></p><p>A: Not really. I would have liked another rush end and another tackle, but they hit on just about everything.</p><p><b>2. If so, what band aide can Jimbo use to shore this up?</b></p><p>A: Doesn't need to. Right now, A&amp;M needs talented depth, and they may be already developing that.</p><p><b>3. Barring unforeseen juniors on the 2019 team roster opting for the NFL, what critical need positions must be filled with the 2020 class?</b></p><p>A: I always want more linebackers and corners. I also have a sneaky feeling running back will be important. </p><p><b>4. Is basketball in a complete rebuild with Coach Williams? (Chuck70)</b></p><p>A: You know, I didn't think so until the last question. Then I researched and yeah, they're in rebuild mode.</p><p><b>Q: It seems like there are alot of scholarships tied up in the WR position on this team. I understand we have to get better at the position (every position really), but how many can Jimbo continue to recruit with so many on campus already? Will we see some tarp door candidates start to fall out soon? (Jessexy)</b></p><p>A: I think the answer is two-pronged. Take a look at the roster, for starters. There's a ton of juniors. An absolute ton of them. You're going to get, at most, two more seasons out of them. That means Quartney Davis, Hezekiah Jones, Jhamon Ausbon, Kendrick Rogers, Camron Buckley and Roshauud Paul (and that's just off the top of my head) are not on the field in 2021. That's a total rebuild. You can't do all that in one class, so you have to split it up. And yes, I do think there will be some guys who aren't around next season.</p><p><b>Q: How many DEs do we take in this class given that rush ends Mowry and Diggs are committed? Would SDE Broughton be it or do you think there is a chance for the Washington DE S. Smalls as well, so 3 or 4 total?</b></p><p><b>They must be confident on Broughton if Sylvester committed to tcu and both are SDEs. I thought he was going to pull the trigger for us </b></p><p>Ok, let's start with this: A&amp;M DOES NOT CARE HOW DE'S ARE DEFINED BY ANYONE BUT THEMSELVES. They have a big DE and a fast DE. They don't always play on the same sides. So Vernon Broughton, Braedon Mowry and Fadil Diggs could play very different roles at A&amp;M than what Rivals or anyone else currently assumes. And yes, I do think there's a chance with Small. He will likely take an official to A&amp;M.</p><p><b> OL Jordan Jefferson...your scouting thoughts on him? I haven't seen much on him anywhere and thought he would be moving on with the coaching change. </b></p><p>He will meet with Josh Henson for the first time (which raised eyebrows for me, considering his proximity) this weekend. We should have a clearer picture after that.</p><p><b> Why the big drop with CB McGlothern? Are you still high on him for one of our CB slots along with J. Williams? How many do we take there and at Safety? What happened to our interest in Bryson Washington and Chris Thompson?...very highly rated, have size and speed plus in our backyard. Looks like we moved on, and are a heavy tu lean. (haas89)</b></p><p>McGlothern wants to go out of state, and frankly, I grew tired of the drama. I'm not sure A&amp;M is seriously recruiting him anymore, considering the other directions they've been going of late. </p><p>How many do they take at each position? I'm guessing two each at least. I would like more at corner. </p><p>As for Washington and Thompson, I think A&amp;M got in on some other guys they think are better fits. We'll see if that's the case.</p><p><b>Q: Best new player who we haven’t seen much of yet? (ChampkindKHOU11) </b></p><p>A: DeMarvin Leal. </p><p>Q: </p><p><br></p><p><br></p>
</div>
</div>
<div class='text-center'>
<rv-share-links print-url='https://tamu.rivals.com/news/aggieyell-mailbag-279/printable' site-name='AggieYell.com'></rv-share-links>
</div>
<div class='trending' ng-if='trendingArticles'>
<div class='article-subheader'>
trending
</div>
<div class='content' ng-cloak ng-repeat='article in trendingArticles'>
<a ng-href='/news/{{article.slug}}'>
<div class='title'>
{{ article.title }}
</div>
<div class='by-line'>
<div class='premium-icon' ng-if='article.kind === "premium"'><svg id="Layer_2" data-name="Layer 2" xmlns="http://www.w3.org/2000/svg" viewbox="0 0 14.54 12"><defs><style>.cls-1{fill:#777f85;}.cls-2{fill:#fff;}</style></defs><title>premium-icon</title>
<polygon class="cls-1" points="12.54 12 0 12 2 0 14.54 0 12.54 12"></polygon><path class="cls-2" d="M10.68,5.28H10.44A4.46,4.46,0,0,0,9,5.5a3.8,3.8,0,0,0-1.19.65,3.87,3.87,0,0,0-.53.51,2.64,2.64,0,0,0-.37.56,3.48,3.48,0,0,0-.2.53,4.28,4.28,0,0,0-.18.58L6.27,9.54H3.18l1.43-6H7.68L7.37,4.77a8,8,0,0,1,.8-0.88A4.6,4.6,0,0,1,9,3.32,3.8,3.8,0,0,1,9.85,3a4.6,4.6,0,0,1,1-.12h0.69l-0.49,2.4H10.71"></path></svg></div>
<div class='live-at'>
{{ timeAgo(article.live_at) }}
</div>
<div class='author'>
{{ article.author_name }}
</div>
</div>
</a>
</div>
</div>
</div>
<div class='spacer'></div>
</div>
</div>
</div>
<div class='enrichment-modules-container-updated siderail'>
<rv-enrichment-module ad-two='null' enrichments='[{"active":true,"type":"Commitment","football":true,"list_id":null,"list_title":null,"position":1},{"active":true,"type":"Rivals","football":true,"list_id":null,"list_title":null,"position":2},{"active":true,"type":"Schedule","football":true,"list_id":null,"list_title":null,"position":3}]' is-super-admin='' is_schedule_football='true' ncaab-schedule-year='2018' ncaaf-schedule-year='2019' site='{"id":139,"legacy_id":893,"name":"AggieYell.com","friendly_name":"Texas A\u0026M","annual_discount":null,"subdomain":"tamu","primary_color":"5d1024","secondary_color":"7f1f38","font_color":"ffffff","short_name":"tamu","maple_ncaaf_team_id":84,"maple_ncaaf_endpoint":"ncaaf/teams/ttj","maple_ncaab_team_id":587,"maple_ncaab_endpoint":"ncaab/teams/tan","maple_college_id":84,"google_analytics_id":"UA-81886974-1"}' twitter-feed='{"id":138,"site_id":139,"handle":null,"list_name":null,"created_at":"2016-02-01T12:25:28.006-06:00","updated_at":"2016-02-01T12:25:28.006-06:00","hashtags":[],"usernames":[],"max_number":null}'></rv-enrichment-module>
</div>
<div class='sticky-footer hidden'>
<div class='text-center'>
<rv-share-links collapsed='false' print-url='https://tamu.rivals.com/news/aggieyell-mailbag-279/printable' site-name='AggieYell.com'></rv-share-links>
</div>
</div>
</div>
<script>
  $(function () {
    if ('false' === 'true') {
      var comment = document.createComment("ads suppressed in development");
  
      document.body.appendChild(comment);
    }else{
      var ad_url = generateDarlaAdUrl('2022733148', 'https://tamu.rivals.com/news/aggieyell-mailbag-279');
  
      var script = document.createElement("script");
      script.src = ad_url;
  
      document.body.appendChild(script);
    }
  });
</script>

<script>
  var _sf_async_config = _sf_async_config || {};
  /** CONFIGURATION START **/
  var byline = document.querySelector('#byline');
  var onetimeAuthors = document.querySelector('#onetime-author');
  if (byline) { // Remove after completely transitioning to new layout (should definitely be done by Jan 1st 2018)
    var i = byline.innerText.indexOf('|');
    var author = byline.innerText.slice(0, i-1);
  } else if (onetimeAuthors) {
    // Possibly multiple authors
    var listAuthors = onetimeAuthors.innerText.split(/ ,| and/);
    var author = listAuthors.join(',');
  } else {
    var bylineNew = document.querySelector('.author-byline .title-sm');
    if (bylineNew) {
      var i = bylineNew.innerText.indexOf('•');
      var author = bylineNew.innerText.slice(0, i-1);
    }
  }
  function getAliasVariable() {
    var host = window.location.host.split('.');
    // add 'n' if it is a Site page
    if (_.include(['n', 'acceptance', 'local'], host[0].toLowerCase()) || host.length == 4) {
      if (_.include(['n'], host[0].toLowerCase())) { host.shift() } // If we are on nationals prod, drop the n subdomain from the alias (aka make it be just rivals.com)
      return host.join('.') + window.location.pathname
    } else {
      host.splice(1, 0, 'n');
      return host.join('.') + window.location.pathname
    }
  }
  _sf_async_config.section = 'article';
  _sf_async_config.authors = (byline || bylineNew || onetimeAuthors) ? author : '';
  _sf_async_config.alias = getAliasVariable();
  _sf_async_config.title = "AggieYell Mailbag";
  _sf_async_config.sections = 'content,content-football,content-football-free,content-article';
  /** CONFIGURATION END **/
  function loadChartbeat() {
    window._sf_endpt = (new Date()).getTime();
    var e = document.createElement('script');
    e.setAttribute('language', 'javascript');
    e.setAttribute('type', 'text/javascript');
    e.setAttribute('src', '//static.chartbeat.com/js/chartbeat_video.js');
    document.body.appendChild(e);
  };
</script>

<div ng-controller='googleTagManagerController as ctrl' ng-init='ctrl.init("tamu", 2042991, null)'>
<iframe height='0' ng-src='{{ ctrl.sourceUrl }}' referrerpolicy='origin' style='display:none;visibility:hidden' width='0'></iframe>
<noscript>
<iframe height='0' ng-src='{{ ctrl.sourceUrl }}' referrerpolicy='origin' style='display:none;visibility:hidden' width='0'></iframe>
</noscript>
</div>

<div class='article-ads-footer'>
<div class='lrec-ads'>
<div class='side-rail-meta lrec-ad' ng-if="showLRECad('footer')">
<div class='side-rail-box'>
<div id='boxLREC'>
<div id='tgtLREC'></div>
</div>
</div>
</div>
</div>
</div>

</div>
</main>
<footer>
<!-- t('footer.about_link', primary_host: primary_host) -->
<ul class='footer-links list-inline'>
<li></li>
<a href='/news/about-us'>About</a>
<a href='https://policies.yahoo.com/us/en/yahoo/privacy/products/rivals/'>Privacy Policy</a>
<a href='/news/contact-us-5'>Contact Us</a>
<a href='/tos'>Terms of Service</a>
<a href='/news/member-services'>Help</a>
</ul>
<div class='copyright-notice'>Certain data provided by STATS, LLC<br/>© 2019 Verizon Media. All rights reserved.</div>
</footer>

</body>
<!-- Begin comScore Tag -->

<script>
  var _comscore = _comscore || [];
  _comscore.push({
    c1: "2",
    c2: "7241469",
    c5: "2022733148",
    c7: "https://tamu.rivals.com/news/aggieyell-mailbag-279"
  });
  (function() {
    var s = document.createElement("script"), el = document.getElementsByTagName("script")[0]; s.async = true;
    s.src = (document.location.protocol == "https:" ? "https://s.yimg.com/lq" : "http://l.yimg.com/d") + "/lib/3pm/cs_0.2.js";
    el.parentNode.insertBefore(s, el);
  })();
</script>

<noscript>
  <img src="https://sb.scorecardresearch.com/p?c1=2&c2=7241469&c7=https%3A%2F%2Ftamu.rivals.com%2Fnews%2Faggieyell-mailbag-279&c5=2022733148&cv=2.0&cj=1" />
</noscript>
<!-- End comScore Tag -->

</html>
